Unusually High Percentage of Recurring Transactions Declined on March 29
Incident Report for GiveGab Enterprise
Resolved
All initial and recurring transactions are processing as expected.

We have discovered that the the cause of the high percentage of declined transactions today is due to inconsistency across calendars dates in a month. Because February only has 28 days, donations that were to be processed on the 29, 30, or 31 have reverted to a 28 processing date. This is expected behavior, although not ideal. This manifested in the platform as follows:

1. Today’s total volume of scheduled transaction attempts is lower due to historical scheduling of monthly plans, but the overall count of declines is within normal levels

2. Today’s total volume of attempts contains a larger percentage than usual of ‘re-tries’ of transactions that have failed in prior days

3. Both these factors mean that the percentage of declines of the total volume is higher today than other days of the month

We're looking into what changes we can make to the platform to address this.
Posted 7 months ago. Mar 29, 2019 - 16:54 EDT
Investigating
On March 29, recurring donations ran as expected. However, the platform saw an unusually high percentage of recurring donations decline overnight. We are investigating the reason for these declines with the payment gateways.

The decline rate for regular form submissions is within expectations across Payment Gateways.
Posted 7 months ago. Mar 29, 2019 - 10:19 EDT
This incident affected: Core Platform (Scheduled Payment Processing).