IP Address blacklisting preventing donation receipt email delivery
Incident Report for GiveGab Enterprise
Resolved
The Yahoo family of EMS systems (including AOL & Comcast) is now delivering messages (donation/registration receipts, administrative notifications) to inboxes.

We'll continue to monitor performance daily, but we believe this issue to be resolved.
Posted 3 months ago. Sep 10, 2018 - 18:10 EDT
Update
The Rackspace's IP address range has successfully been removed from all 3rd party blacklists. We continue to actively monitor those blacklists.

Unfortunately, the Yahoo family of EMS systems (including AOL) continues to prevent messages (donation/registration receipts, administrative notifications) from being delivered to desired inboxes. We're actively discussing possible resolutions with the Yahoo Mail team.
Posted 3 months ago. Sep 09, 2018 - 16:25 EDT
Monitoring
Most 3rd party blacklists have been corrected and updated, however a few have not yet updated based on our changes. Specifically we're aware of issues receiving mail at addresses managed by Yahoo and Comcast
Posted 3 months ago. Sep 06, 2018 - 17:21 EDT
Identified
Certain 3rd partyBlacklist services like Proofpoint have included our upstream vendor Rackspace's AP address range on their blacklists. While our platform is successfully sending emails (donation receipts, scheduled report deliveries etc.), certain EMS (email service providers) like Yahoo, Comcast and MS Outlook are preventing those messages from being delivered to the desired inboxes.

We're actively working with our Vendor and these 3rd Party services to remove the IP Address range from the blacklists to restore delivery.
Posted 3 months ago. Sep 05, 2018 - 14:12 EDT
This incident affected: Admin Control Panel.