Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 01, 2020 - 05:00 EST
Scheduled
We will be performing scheduled maintenance for required security updates.
During this maintenance window, we expect that: - All embedded Donation, Registration and RFI forms will NOT display and there not be able to process transactions - All other embedded widgets will NOT display - Scheduled payment processing (ongoing and installment payments) will transact at their normally scheduled time
Posted Oct 28, 2020 - 16:53 EDT
This scheduled maintenance affected: Core Platform (Donation Processing Forms).