Chrome Browser version 87+ Displays security warning on Administrative Login
Incident Report for GiveGab Enterprise
Resolved
The code patch was deployed successfully after the close of business (Pacific Time) on Tuesday, Dec. 15th. We are no longer able to reproduce the warning message in Google Chrome browser v. 87+. We have been monitoring the platform throughout the day and have not received any reports of the warning message from other Admins.
Posted Dec 16, 2020 - 18:05 EST
Update
We have identified a fix for this issue and plan to implement a code patch after the close of business (Pacific Time) on Tuesday, Dec. 15th.

This code fix will be applied exclusively to those servers that handle the Administrative Control Panel. This code patch will NOT impact any servers responsible for the display of embedded donation, registration or RFI forms. Individual donors/registrants using embedded forms at the time the code patch is deployed will not be impacted.

In the meantime, Admins using the Google Chrome web browser who are receiving the warning message can:
1) click the 'Send Anyway' button in the lower left of the error message screen
2) use a different web browser to access the Admin Control Panel
Posted Dec 14, 2020 - 18:49 EST
Identified
We're aware that the recent version 87 release of the Chrome browser on Windows and MacOS displays an warning message about information not being secure (see https://blog.chromium.org/2020/08/protecting-google-chrome-users-from.html) when Admin users attempt to login to the Administrative control panel.

The display of the message is a change in how Google has chosen to identify the concern from past browser versions and the reason it is now appearing. While the Enterprise login process is absolutely secure and has been certified via our PCI Level 1 audits, the process is currently not transparent enough to the new Google Chrome browser version and the warning message is displayed out of an abundance of caution.

Keeping in mind the potential disruption to Admin access during end-of-year fundraising, we're investigating the quickest path to resolution so the Google Chrome browser better understands the login process and removes the warning.

NOTE: This warning message does NOT impact the display of embedded donation, registration or RFI forms. Individual donors/registrants do not receive a warning message when viewing embedded forms on your site.
Posted Dec 14, 2020 - 12:15 EST
This incident affected: Core Platform (Admin Control Panel).