Unexpected charging of Recurring payments
Incident Report for GiveGab Enterprise
Resolved
The code patch containing a guard ensuring that any payment schedule charge request made by the platform is in its proper sequence was successfully applied after business hours on Friday, September 6th.

We have monitored the daily scheduled transactions and have not seen a re-occurrence of any out-of-sequence charges and we believe the issue to be resolved.
Posted 7 days ago. Sep 09, 2019 - 00:32 EDT
Update
The refunding all of the out of sequence charges was completed at approximately 8:15 pm Central Time on Thursday, September 5th.

A code patch containing a guard ensuring that any payment schedule charge request made by the platform is in its proper sequence is planned for after hours on Friday, September 6th.
Posted 9 days ago. Sep 06, 2019 - 13:02 EDT
Monitoring
Around 7:15 Central Time this morning, we confirmed that a limited number of recurring plans were charged out of sequence. Donors were only charged once, however, they were charged on a different date than originally scheduled through their recurring plan. None of these charges were duplicates of the today's expected scheduled charges performed by the platform at 2:00 am Central time.

At 3pm Central time we began refunding all of the out of sequence charges. These charges should appear as VOIDs at respective Payment Gateways because they were submitted within 24hrs of the original errant charges. This incident will be updated when all of the refunds have completed.
Posted 10 days ago. Sep 05, 2019 - 19:54 EDT
Update
We are continuing to investigate this issue.
Posted 10 days ago. Sep 05, 2019 - 12:15 EDT
Investigating
We are currently investigating a report of unexpected charging of specific recurring plans this morning beginning around 7:00 am CT. We do not believe these are duplicate charges for payments made during our normal recurring process at 2:30 am CT, but rather charges to specific payment plans that would not have normally charged today.
Posted 10 days ago. Sep 05, 2019 - 12:15 EDT
This incident affected: Core Platform (Scheduled Payment Processing).