Payment Detail fields not rendering
Incident Report for GiveGab Enterprise
Postmortem

Included in our October 7 Platform Update was the addition of code necessary to better identify forms when embedded in a Form Chooser widget. That code was intended to clarify which set of 'Payment Details' fields to submit in the rare situation when both forms in the Form Chooser had information entered into the fields but only one form was submitted.

Unfortunately that code change inadvertently impacted individual forms where one or both of the the following configurations was true:

  • the 'Campaign Management' > '[CAMPAIGN NAME]' > 'Details' > 'Channel Prefix' begins with an integer (0-9)
  • the 'Campaign Management' > '[FORM NAME]' > 'Form Details' > 'Hosted Page' begins with an integer (0-9)

Forms with either of the above were not rendering payment fields after the platform update. The code patch corrected the condition and the Payment Details were displaying on all forms as expected.

Posted Oct 12, 2020 - 15:48 EDT

Resolved
The code patch was deployed successfully and the issue has been resolved.
Posted Oct 08, 2020 - 16:18 EDT
Update
We will be deploying a code patch to address this issue shortly after 1pm CT. During this patch window, we expect that:
- Any currently logged in Admins will automatically be logged out and will not be able to log in until the release is completed (Administrative Control Panel)
- All embedded Donation, Registration and RFI forms will continue to display and process submissions/transactions
- Secure Report URLs will function, however the delivery of the result file may take longer than usual for requests initiated during the release window (API)
- RESTful XML endpoints will function, however the delivery of the results may take longer than usual for requests initiated during the release window (API)
- Scheduled payment processing (ongoing and installment payments) will transact at their normally scheduled time
Posted Oct 08, 2020 - 13:59 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 08, 2020 - 12:29 EDT
Identified
We are aware of an issue with specific form configurations that results in the Payment Details fields not rendering as expected.

Our team has determined the root cause of the issue and is currently working on a code patch. We will let you know once the fix has been implemented.

If you have any questions, please reach out to our team via enterprise-support@givegab.com.
Posted Oct 08, 2020 - 12:28 EDT
This incident affected: Core Platform (Donation Processing Forms).